ace-iac-day-zero : enable_active_mesh = var.active_mesh

  • 15 April 2022
  • 7 replies

hello all experts,


i run into the error as below and the detail is in  the attachment


Error: Unsupported argument
on .terraform/modules/aws_spoke_1/ line 16, in resource "aviatrix_spoke_gateway" "default":
enable_active_mesh = var.active_mesh
An argument named "enable_active_mesh" is not expected here.

Best answer by Dennis_Hagens 15 April 2022, 11:25

View original

7 replies

Badge +2

According to the module documentation he statement should be 'active_mesh' instead of 'enable_active_mesh'.


The module and probably the arguments to call them are fine. What I think the issue is here, is the fact that the option to configure active_mesh was removed from 6.6, as it is now always enabled. With the removal of support from the controller and Terraform provider, you run into this error. So it suggests your provider and controller version are too new for the code you are running, which I think was written to be executed against controller version 6.5 and provider version <2.21.0 as per the release notes:

Userlevel 5

Hi Ken yau , if you deployed the Aviatrix platform from the Sandbox Starter Tool (SST) in late Feb or so, the Controller would have been built on version 6.5, where active_mesh was a valid option. Since mid-March, the SST now defaults to 6.6, where active_mesh is no longer valid, as Dennis mentioned. 

So, if you started off a fresh SST instance launched in the past month, you should be good. All the IaC lab guides and training videos work off of that.

thank you Aviatrix Certified Engineer  and Dennis Hagens


in this case - i tried to find an older SST in AWS AMI but no luck. 

Can you plz suggest how i can solve this problem? Thanks., 

Userlevel 5

Ken yau do not look for an older SST AMI. Simply use the one linked from the official doc.

Aviatrix Certified Engineer ,the error i encounter now is due to i use the new SST AMI. 

Do you have a good solution for me? Thanks 

Userlevel 5

Ken yau sent you an email to the email linked to your Community account. Please check that.